Open navigation

Kaltura Common Problems and Solutions

Problem:

When accessing Kaltura media in Moodle, the following message is presented: 

It seems your browser is blocking 3rd party session cookies which are required for the Kaltura application. To resolve this issue, please update your settings to allow 3rd party cookies.

Cause:

For Kaltura to work, there needs to be effective communication between two servers: one housing Moodle, and the other housing Kaltura. Part of that successful communication process is the sharing of cookies that identify your computer as having permission to access and display the video content. When this happens, your computer is accepting a cookie from Kaltura in order to communicate with Moodle. This is known as a 3rd party cookie. In the simplest terms, the cookie facilitates the exchange of information between the two systems. When you see the media content appear, your computer is accepting the Kaltura 3rd party cookie.

Some individuals may have cookies blocked on their computer browser. In particular, they may choose to block 3rd party cookies. Often, 3rd party of cookies are used by web businesses to track their site visitation and use. Keep in mind, the Kaltura cookie only facilitates the interplay between Moodle and Kaltura. It is not tracking larger web activity, but you need the browser you use with Moodle to accept 3rd party cookies (like Kaltura’s) in order for Moodle and Kaltura to communicate effectively.

Workarounds:

Generally, it is recommended that you use a desktop browser like Chrome or Firefox to view Kaltura content in Moodle. See the workarounds below if you are using one of the browsers this error generally manifests in:

Macbooks and iMacs:

Safari: When the Safari browser is open, navigate to Safari > Preferences > Privacy
For users on Operating System (OS) 10.13 or newer, un-check "Prevent cross-site tracking" and "Block all cookies." 
For users on Operating System (OS) 10.12 or older, select "Always allow" on Cookies and Website Data

Chrome: When the Chrome browser is open, navigate to Chrome > Preferences > Advanced (Privacy & Security Group) Site Settings > Cookies & Site Data
Check "Allow sites to save and read cookie data" and un-check "Block third party cookies." 


iOS Devices (iPhone, iPad)

Safari: Navigate to Settings > Safari
Un-check "Prevent Cross-Site Tracking."
Un-check "Block All Cookies." 

Chrome: To enable cookies on an iOS device through Chrome, you will first need to adjust the third party settings from a desktop, then sync your Chrome account so those third party settings are reflected in the device. 

On a trusted computer, open Chrome and click the user icon at the top right. 
Click "Turn on sync..."   
If you are not already signed in, you will be prompted to sign into your Google account or create one. 

Once you have synced your Chrome account on both devices, you will need to enable third party cookies. 

In the Chrome browser, at the top right, click More > Settings. (The More icon is the three dots.) 
Scroll to the bottom, and click on Advanced
In the Privacy and Security section, click Site Settings
Click Cookies and site data, then de-select the Block third-party cookies option (should be gray, not blue).

Firefox
Kaltura will not work the Firefox browser. Utilizing Chrome or Safari is recommended. 

PC

Chrome: Navigate to Settings > Advanced > Site Settings
Check "Allow sites to have and read cookie data."
Un-check "Block third-party cookies." 


Android Devices 

Chrome: Navigate to Settings in Chrome, then Site Settings > Cookies.
Check "Allow sites to save and read cookie data."
Un-check "Block third-party cookies."

Firefox: Navigate to the Settings in Firefox, then Privacy > Cookies
Select either "Enabled" or "Enabled, excluding tracking cookies."